Thread (22 messages) 22 messages, 4 authors, 2021-09-23

Re: [PATCH v3 1/3] btrfs: rename btrfs_bio to btrfs_io_context

From: Qu Wenruo <hidden>
Date: 2021-09-17 11:24:36


On 2021/9/17 19:19, David Sterba wrote:
On Wed, Sep 15, 2021 at 03:17:16PM +0800, Qu Wenruo wrote:
quoted
The structure btrfs_bio is used by two different sites:

- bio->bi_private for mirror based profiles
   For those profiles (SINGLE/DUP/RAID1*/RAID10), this structures records
Why is SINGLE here?
For single we use the same routine as RAID1/DUP/etc, it's
submit_stripe_bio() doing the remapping.

Thus there is really only two types, non-RAID56 and RAID56.

Thanks,
Qu
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help