Write time tree block corruption detected
flat view
From: <hidden>
Date: 2021-05-30 21:30:12
Hello,
On linux 5.3.18-lp152.75-default (openSUSE 15.2), I got the following error message:
[33573.070335] BTRFS critical (device sda2): corrupt leaf: root=3 block=531135201280 slot=0 devid=1 invalid bytes used: have 64503152640 expect [0, 64424509440]
[33573.070338] BTRFS error (device sda2): block=531135201280 write time tree block corruption detected
[33573.071909] BTRFS: error (device sda2) in btrfs_commit_transaction:2264: errno=-5 IO failure (Error while writing out transaction)
[33573.071911] BTRFS info (device sda2): forced readonly
[33573.071913] BTRFS warning (device sda2): Skipping commit of aborted transaction.
[33573.071915] BTRFS: error (device sda2) in cleanup_transaction:1823: errno=-5 IO failure
[33573.071917] BTRFS info (device sda2): delayed_refs has NO entry
[33577.283856] BTRFS info (device sda2): delayed_refs has NO entry
Probably related is that the filesystem had less than 1 GiB free when this occurred. Rebooting and deleting some files seemed to have resolved it for a while, until:
[ 5201.020901] BTRFS critical (device sda2): corrupt leaf: root=3 block=536671682560 slot=0 devid=1 invalid bytes used: have 64503152640 expect [0, 64424509440]
[ 5201.020904] BTRFS error (device sda2): block=536671682560 write time tree block corruption detected
[ 5201.022983] BTRFS: error (device sda2) in btrfs_commit_transaction:2264: errno=-5 IO failure (Error while writing out transaction)
[ 5201.022985] BTRFS info (device sda2): forced readonly
[ 5201.022987] BTRFS warning (device sda2): Skipping commit of aborted transaction.
[ 5201.022988] BTRFS: error (device sda2) in cleanup_transaction:1823: errno=-5 IO failure
[ 5201.022991] BTRFS info (device sda2): delayed_refs has NO entry
[ 5201.023071] BTRFS info (device sda2): delayed_refs has NO entry
after a successful scrub and balance. This time df reports 8.8GiB free, but:
# btrfs fi df /
Data, single: total=55.98GiB, used=47.18GiB
System, single: total=32.00MiB, used=16.00KiB
Metadata, single: total=2.00GiB, used=1.01GiB
GlobalReserve, single: total=512.00MiB, used=0.00B
# btrfs fi show /
Label: none uuid: 44c67fa4-e2c4-4da5-9d07-98959ff77bc4
Total devices 1 FS bytes used 48.19GiB
devid 1 size 60.00GiB used 60.07GiB path /dev/sda2
60.07GiB used out of 60.00GiB! I recall that this is what I saw the first time too, so it might be related to the cause.
Is there anything I can do to ensure that the filesystem is not further damaged and that the issue is resolved?
Regards,
Petros