Re: [PATCH v2 02/15] btrfs: use min() to replace open-code in btrfs_invalidatepage()
From: Anand Jain <hidden>
Date: 2021-03-15 12:04:16
On 10/03/2021 17:08, Qu Wenruo wrote:
In btrfs_invalidatepage() we introduce a temporary variable, new_len, to update ordered->truncated_len. But we can use min() to replace it completely and no need for the variable. Signed-off-by: Qu Wenruo <redacted> ---
Reviewed-by: Anand Jain [off-list ref] -Anand
quoted hunk ↗ jump to hunk
fs/btrfs/inode.c | 6 ++---- 1 file changed, 2 insertions(+), 4 deletions(-)diff --git a/fs/btrfs/inode.c b/fs/btrfs/inode.c index 52dc5f52ea58..2973cec05505 100644 --- a/fs/btrfs/inode.c +++ b/fs/btrfs/inode.c@@ -8405,15 +8405,13 @@ static void btrfs_invalidatepage(struct page *page, unsigned int offset, */ if (TestClearPagePrivate2(page)) { struct btrfs_ordered_inode_tree *tree; - u64 new_len; tree = &inode->ordered_tree; spin_lock_irq(&tree->lock); set_bit(BTRFS_ORDERED_TRUNCATED, &ordered->flags); - new_len = start - ordered->file_offset; - if (new_len < ordered->truncated_len) - ordered->truncated_len = new_len; + ordered->truncated_len = min(ordered->truncated_len, + start - ordered->file_offset); spin_unlock_irq(&tree->lock); if (btrfs_dec_test_ordered_pending(inode, &ordered,