Re: [PATCH v3 06/12] btrfs: rename need_do_async_reclaim
From: David Sterba <hidden>
Date: 2021-01-27 10:13:12
On Fri, Oct 09, 2020 at 09:28:23AM -0400, Josef Bacik wrote:
quoted hunk ↗ jump to hunk
All of our normal flushing is asynchronous reclaim, so this helper is poorly named. This is more checking if we need to preemptively flush space, so rename it to need_preemptive_reclaim. Reviewed-by: Nikolay Borisov <redacted> Signed-off-by: Josef Bacik <josef@toxicpanda.com> --- fs/btrfs/space-info.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-)diff --git a/fs/btrfs/space-info.c b/fs/btrfs/space-info.c index 0f84bee57c29..f37ead28bd05 100644 --- a/fs/btrfs/space-info.c +++ b/fs/btrfs/space-info.c@@ -799,9 +799,9 @@ btrfs_calc_reclaim_metadata_size(struct btrfs_fs_info *fs_info, return to_reclaim; } -static inline int need_do_async_reclaim(struct btrfs_fs_info *fs_info, - struct btrfs_space_info *space_info, - u64 used) +static inline bool need_preemptive_reclaim(struct btrfs_fs_info *fs_info,
Following patches add more code to that function so it's not really suitable for 'static inline', I'd rather drop it.