Re: [PATCH 2/2] Btrfs: kill root from btrfs_is_free_space_inode
From: Liu Bo <hidden>
Date: 2012-07-18 01:04:13
On 07/17/2012 09:43 PM, David Sterba wrote:
On Tue, Jul 10, 2012 at 07:28:39PM +0800, Liu Bo wrote:quoted
Since root can be fetched via BTRFS_I macro directly, we can save an args for btrfs_is_free_space_inode().I see a great opportunity to rename the function :) It does not cover just the free space inode anymore and it'll be more confusing with the btree inode case. I don't have a better name than btrfs_is_special_inode, but am not completely satisfied.
Hi David, Seems that my patch's title is confusing you... I made these patches to make this function return true if the inode is a free space inode or an inode cache inode, but not the btree inode. Or am I missing something? :) thanks, liubo
david -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html