crypto api · Maintained
Maintainers
- M Herbert Xu <herbert@gondor.apana.org.au>
- M "David S. Miller" <davem@davemloft.net>
Paths
- F
Documentation/crypto/ - F
Documentation/devicetree/bindings/crypto/ - F
arch/*/crypto/ - F
crypto/ - F
drivers/crypto/ - F
include/crypto/ - F
include/linux/crypto*
Last 30 days
Recent patches
Most-recent 21 patches in this subsystem on linux-bluetooth, ordered by date desc.
-
STALE97d
[PATCH] crypto: af_alg - Add af_alg_restrict sysctl, defaulting to 1
2026-06-22 · Eric Biggers <ebiggers@kernel.org> -
STALE897d
LANDED [PATCH v2 10/25] crypto: virtio - drop owner assignment
2024-03-31 · Krzysztof Kozlowski <hidden> -
STALE922d
[PATCH 07/22] crypto: virtio - drop owner assignment
2024-03-27 · Krzysztof Kozlowski <hidden> -
STALE1191d
LANDED [PATCH 1/3] virtio-crypto: fixup potential cpu stall when free unused bufs
2023-06-09 · Xianting Tian <hidden> -
STALE1295d
[RFC PATCH 1/3] net: Drop the size argument from ->sendmsg()
2023-03-22 · David Howells <dhowells@redhat.com> -
STALE1338d
[v2 PATCH 10/17] crypto: api - Use data directly in completion function
2023-02-08 · Herbert Xu <herbert@gondor.apana.org.au> -
STALE1338d
[PATCH 10/17] crypto: api - Use data directly in completion function
2023-02-06 · "Herbert Xu" <herbert@gondor.apana.org.au> -
STALE1695d
[PATCH][next] treewide: Replace zero-length arrays with flexible-array members
2022-02-15 · "Gustavo A. R. Silva" <gustavoars@kernel.org> -
STALE1818d
LANDED [PATCH RFC] virtio: wrap config->reset calls
2021-10-13 · "Michael S. Tsirkin" <mst@redhat.com> -
STALE2253d
Re: [PATCH 12/26] netfilter: switch nf_setsockopt to sockptr_t
2020-07-27 · Christoph Hellwig <hch@lst.de> -
STALE2253d
Re: [PATCH 19/26] net/ipv6: switch ipv6_flowlabel_opt to sockptr_t
2020-07-27 · Christoph Hellwig <hch@lst.de> -
STALE2253d
[PATCH 25/26] net: pass a sockptr_t into ->setsockopt
2020-07-23 · Christoph Hellwig <hch@lst.de> -
STALE2270d
[PATCH 24/24] net: pass a sockptr_t into ->setsockopt
2020-07-20 · Christoph Hellwig <hch@lst.de> -
STALE2273d
[PATCH 22/22] net: make ->{get,set}sockopt in proto_ops optional
2020-07-17 · Christoph Hellwig <hch@lst.de> -
STALE2306d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2305d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2346d
[PATCH 01/20] crypto: hash - introduce crypto_shash_tfm_digest()
2020-05-02 · Eric Biggers <ebiggers@kernel.org> -
STALE2307d
[PATCH v2 2/2] crypto: Remove unnecessary memzero_explicit()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE2307d
[PATCH 2/2] crypto: Remove unnecessary memzero_explicit()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE2307d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE3755d
Re: Doing crypto in small stack buffers (bluetooth vs vmalloc-stack crash, etc)
2016-06-28 · George Spelvin <hidden>