Re: [PATCH 4/5] mm: add mm_get_static_huge_zero_folio() routine
From: David Hildenbrand <hidden>
Date: 2025-06-16 09:14:14
Also in:
linux-fsdevel, linux-mm, lkml
On 12.06.25 22:54, Pankaj Raghav (Samsung) wrote:
On Thu, Jun 12, 2025 at 07:09:34AM -0700, Dave Hansen wrote:quoted
On 6/12/25 03:50, Pankaj Raghav wrote:quoted
+/* + * mm_get_static_huge_zero_folio - Get a PMD sized zero folioIsn't that a rather inaccurate function name and comment?I agree. I also felt it was not a good name for the function.quoted
The third line of the function literally returns a non-PMD-sized zero folio.quoted
+ * This function will return a PMD sized zero folio if CONFIG_STATIC_PMD_ZERO_PAGE + * is enabled. Otherwise, a ZERO_PAGE folio is returned. + * + * Deduce the size of the folio with folio_size instead of assuming the + * folio size. + */ +static inline struct folio *mm_get_static_huge_zero_folio(void) +{ + if(IS_ENABLED(CONFIG_STATIC_PMD_ZERO_PAGE)) + return READ_ONCE(huge_zero_folio); + return page_folio(ZERO_PAGE(0)); +}This doesn't tell us very much about when I should use: mm_get_static_huge_zero_folio() vs. mm_get_huge_zero_folio(mm) vs. page_folio(ZERO_PAGE(0)) What's with the "mm_" in the name? Usually "mm" means "mm_struct" not Memory Management. It's really weird to prefix something that doesn't take an "mm_struct" with "mm_"Got it. Actually, I was not aware of this one.quoted
Isn't the "get_" also a bad idea since mm_get_huge_zero_folio() does its own refcounting but this interface does not?Agree.quoted
Shouldn't this be something more along the lines of: /* * pick_zero_folio() - Pick and return the largest available zero folio * * mm_get_huge_zero_folio() is preferred over this function. It is more * flexible and can provide a larger zero page under wider * circumstances. * * Only use this when there is no mm available. * * ... then other comments */ static inline struct folio *pick_zero_folio(void) { if (IS_ENABLED(CONFIG_STATIC_PMD_ZERO_PAGE)) return READ_ONCE(huge_zero_folio); return page_folio(ZERO_PAGE(0)); } Or, maybe even name it _just_: zero_folio()I think zero_folio() sounds like a good and straightforward name. In most cases it will return a ZERO_PAGE() folio. If CONFIG_STATIC_PMD_ZERO_PAGE is enabled, then we return a PMD page.
"zero_folio" would be confusing I'm afraid. At least with current "is_zero_folio" etc. "largest_zero_folio" or sth. like that might make it clearer that the size we are getting back might actually differ. -- Cheers, David / dhildenb