Thread (11 messages) 11 messages, 4 authors, 2023-08-12

Re: [PATCH -next v3] block: remove init_mutex and open-code blk_iolatency_try_init

From: Yu Kuai <hidden>
Date: 2023-08-11 09:23:11
Also in: cgroups

Hi, Michal

在 2023/08/11 17:17, Michal Koutný 写道:
On Fri, Aug 11, 2023 at 04:53:44PM +0800, Yu Kuai [off-list ref] wrote:
quoted
Yes, it'm implemented in the upper layer that rq_qos_add() and
blkcg_activate_policy() should be atmoic, and currently there is no
comments for that.
The check (iolat_rq_qos()) and use (activating the policy) should be the
atomic pair.
quoted
Perhaps it's better to add some comments like following in rq_qos_add()
instead?
Honestly, I find the current variant (v3) good as it is -- closest to
the pair of the operations.

(But it's merely a comment so ¯\_(ツ)_/¯)
Yes, it's just a comment.

Lingfeng, can you resend this patch with the following fixed?

 > lockdep_assert_held(ctx.bdev->bd_queue->rq_qos_mutex);

should be:
lockdep_assert_held(&ctx.bdev->bd_queue->rq_qos_mutex);

And you can keep my review tag.

Thanks,
Kuai
Michal
  
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help