RE: [RFC PATCH] iov_iter: Convert iterate*() to inline funcs
From: David Laight <hidden>
Date: 2023-08-15 11:14:18
Also in:
linux-fsdevel, linux-mm, lkml
From: David Laight <hidden>
Date: 2023-08-15 11:14:18
Also in:
linux-fsdevel, linux-mm, lkml
From: David Howells
Sent: 11 August 2023 15:32 Convert the iov_iter iteration macros to inline functions to make the code easier to follow. Ideally, the optimiser would produce much the same code in both cases, but the revised code ends up a bit bigger.
... Actually quite typical because inlining happens much later on. I suspect that the #define benefits from the compile front-end optimising constants. David - Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK Registration No: 1397386 (Wales)