Thread (36 messages) 36 messages, 9 authors, 2023-09-19

Re: [PATCH v2 02/10] qcom_scm: scm call for deriving a software secret

From: Eric Biggers <ebiggers@kernel.org>
Date: 2023-07-22 04:18:31
Also in: linux-arm-msm, linux-fscrypt, linux-mmc, linux-scsi

On Fri, Jul 21, 2023 at 08:50:56PM -0700, Bjorn Andersson wrote:
quoted
+/**
+ * qcom_scm_derive_sw_secret() - Derive SW secret from wrapped key
+ * @wrapped_key: the wrapped key used for inline encryption
+ * @wrapped_key_size: size of the wrapped key
Following my reply on patch 7, how about dropping the "_key" suffix on
these.
quoted
+ * @sw_secret: the secret to be derived which is exactly the secret size
Similarly the "sw_" prefix doesn't see to add value, please omit it.
The name 'sw_secret' comes from the block layer support
(https://lore.kernel.org/linux-block/20221216203636.81491-2-ebiggers@kernel.org/ (local)).
It is helpful to call it 'sw_secret' instead of 'secret', as there are other
types of secrets involved that are not accessible to software (Linux).

- Eric
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help