Thread (90 messages) 90 messages, 5 authors, 2023-01-19

Re: [PATCH v6 01/34] vfs: Unconditionally set IOCB_WRITE in call_write_iter()

From: David Howells <dhowells@redhat.com>
Date: 2023-01-17 08:29:29
Also in: linux-fsdevel, lkml

Christoph Hellwig [off-list ref] wrote:
I suspect the best is to:

 - rename init_sync_kiocb to init_kiocb
 - pass a new argument for the destination
Do you mean the direction rather than the destination?
   to it.  I'm not entirely
   sure if flags is a good thing, or an explicit READ/WRITE might be
   better because it's harder to get wrong, even if a the compiler
   might generate worth code for it.
 - also use it in the async callers (io_uring, aio, overlayfs, loop,
   nvmet, target, cachefs, file backed swap)
David
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help