Thread (29 messages) 29 messages, 6 authors, 2022-05-31

Re: [PATCHv4 5/9] block: add a helper function for dio alignment

From: Christoph Hellwig <hch@lst.de>
Date: 2022-05-31 06:22:35
Also in: linux-fsdevel

On Thu, May 26, 2022 at 10:54:02AM +0900, Damien Le Moal wrote:
Nit: The name of this helper really suggest a bool return, which would be a more
flexible interface I think:

	if (!blkdev_dio_aligned(bdev, pos, iter))
		return -EINVAL; <-- or whatever error code the caller wants.

And that will allow you to get rid of the ret variable in a least
__blkdev_direct_IO_async.
I agree, a bool return looks more natural here.

Otherwise this looks good to me.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help