Thread (1 message) 1 message, 1 author, 2022-03-08

Re: [PATCH 04/14] sd: rename the scsi_disk.dev field

From: Martin K. Petersen <hidden>
Date: 2022-03-08 03:25:25
Also in: linux-scsi

Christoph,
dev is very hard to grab for.
grep?
Give the field a more descriptive name and documents it's purpose.
its
quoted hunk
+
+	/*
+	 * This device is mostly just used to show a bunch of attributes in a
+	 * weird place.  In doubt don't add any new users, and most importantly
+	 * don't use if for any actual refcounting.
+	 */
+	struct device	disk_dev;
I agree with Bart that this should be more explicit about the
/sys/class/scsi_disk location. Otherwise it is not clear which device
the comment refers to.

Otherwise OK.

Acked-by: Martin K. Petersen <redacted>

-- 
Martin K. Petersen	Oracle Linux Engineering
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help