Thread (28 messages) 28 messages, 4 authors, 2021-12-10

Re: [PATCH 1/5] blk-mq: move srcu from blk_mq_hw_ctx to request_queue

From: Bart Van Assche <bvanassche@acm.org>
Date: 2021-11-19 04:30:54
Also in: linux-nvme, linux-scsi

On 11/18/21 18:18, Ming Lei wrote:
+	bool			alloc_srcu;
I found the following statement multiple times in this patch:

WARN_ON_ONCE(q->alloc_srcu != !!(q->tag_set->flags & BLK_MQ_F_BLOCKING));

Does this mean that the new q->alloc_srcu member variable can be left out
and that it can be replaced with the following test?

q->tag_set->flags & BLK_MQ_F_BLOCKING

Please note that I'm not concerned about the memory occupied by this
variable but only about avoiding redundancy.

If this variable is retained it probably should be renamed, e.g. "has_srcu"
instead of "alloc_srcu".

Thanks,

Bart.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help