Re: [PATCH v4 0/4] blk-crypto cleanups
From: Eric Biggers <ebiggers@kernel.org>
Date: 2021-10-05 17:26:20
Also in:
dm-devel, linux-mmc, linux-scsi
From: Eric Biggers <ebiggers@kernel.org>
Date: 2021-10-05 17:26:20
Also in:
dm-devel, linux-mmc, linux-scsi
On Wed, Sep 29, 2021 at 09:35:56AM -0700, Eric Biggers wrote:
This series renames struct blk_keyslot_manager to struct
blk_crypto_profile, as it is misnamed; it doesn't always manage
keyslots. It's much more logical to think of it as the
"blk-crypto profile" of a device, similar to blk_integrity_profile.
This series also improves the inline-encryption.rst documentation file,
and cleans up blk-crypto-fallback a bit.
This series applies to block/for-next.
Changed v3 => v4:
- Rebased onto block/for-next to resolve a conflict due to
'struct request' being moved.Ping? - Eric