Re: [PATCH v2 3/4] block/mq-deadline: Stop using per-CPU counters
From: Bart Van Assche <bvanassche@acm.org>
Date: 2021-09-28 17:35:06
From: Bart Van Assche <bvanassche@acm.org>
Date: 2021-09-28 17:35:06
On 9/27/21 10:51 PM, Hannes Reinecke wrote:
On 9/28/21 12:03 AM, Bart Van Assche wrote:quoted
+ dd->per_prio[prio].stats.merged++;Why don't you convert the macro 'dd_count()' to work with the new structure?
Hi Hannes, The dd_count() macro would look as follows if it would have been kept: #define dd_count(dd, event_type, prio) (dd)->per_prio[(prio)].stats.event_type++ I prefer to open-code such a macro since I think that the open-coded version is as easy to read as when the dd_count() macro would have been converted. Thanks, Bart.