On 9/16/21 10:22 AM, Eric Biggers wrote:
External email: Use caution opening links or attachments
From: Eric Biggers <redacted>
For clarity, avoid using just the "blk_crypto_" prefix for functions and
structs that are specific to blk-crypto-fallback. Instead, use
"blk_crypto_fallback_". Some places already did this, but others
didn't.
This is also a prerequisite for using "struct blk_crypto_keyslot" to
mean a generic blk-crypto keyslot (which is what it sounds like).
Rename the fallback one to "struct blk_crypto_fallback_keyslot".
Reviewed-by: Christoph Hellwig <hch@lst.de>
Signed-off-by: Eric Biggers <redacted>
Looks good, it might be useful to mention this patch doesn't change
any functionality, not a hard requirement though.
Reviewed-by: Chaitanya Kulkarni <kch@nvidia.com>