Damien,
I like it, but a bit long-ish. Do you think shortening to access_range
would be acceptable ?
But doesn't 'access_range' imply that there are ranges that you can't
access? I think 'independent' is more important and 'access' is just a
clarification.
Adding independent does make everything even more obvious, but names become
rather long. Not an issue for the sysfs directory I think, but
I do think it's important that the sysfs directory in particular is the
full thing. It's a user-visible interface.
If the internal interfaces have a shorthand I guess that's OK.
struct blk_independent_access_range {
...
sector_t sector;
sector_t nr_sectors;
}
is rather a long struct name.
True, but presumably you'd do:
struct blk_independent_access_range *iar;
in a variable declaration and be done with it. So I don't think the type
is a big deal. Where it becomes unwieldy is:
blk_rq_independent_access_range_frobnicate();
Anyway. Running out of ideas. autonomous_range? sequestered_range?
--
Martin K. Petersen Oracle Linux Engineering