Christoph,
Move the SCSI-specific bsg code in the SCSI midlayer instead of in the
common bsg code. This just keeps the common bsg code block/ and also
allows building it as a module.
+static const struct bsg_ops bsg_scsi_ops = {
+ .check_proto = bsg_scsi_check_proto,
+ .fill_hdr = bsg_scsi_fill_hdr,
+ .complete_rq = bsg_scsi_complete_rq,
+ .free_rq = bsg_scsi_free_rq,
+};
Maybe just cosmetic, but now that this code lives in scsi_bsg.c (which I
do like), I think these functions should be named
scsi_bsg_check_proto(), etc.
--
Martin K. Petersen Oracle Linux Engineering