Re: [PATCH 19/24] scsi: rename CONFIG_BLK_SCSI_REQUEST to CONFIG_SCSI_COMMON
From: Martin K. Petersen <hidden>
Date: 2021-07-22 17:51:51
Christoph,
CONFIG_BLK_SCSI_REQUEST is rather misnamed now as it just enabled building a small amount of code shared by the scsi initiator, target and consumers of the scsi_request passthrough API. Rename it and also allow building it as a module.
Build now fails. Needs:
diff --git a/drivers/scsi/scsi_common.c b/drivers/scsi/scsi_common.c
index 8aac4e5e8c4c..4fb16e70dddf 100644
--- a/drivers/scsi/scsi_common.c
+++ b/drivers/scsi/scsi_common.c@@ -7,9 +7,12 @@ #include <linux/kernel.h> #include <linux/string.h> #include <linux/errno.h> +#include <linux/module.h> #include <asm/unaligned.h> #include <scsi/scsi_common.h> +MODULE_LICENSE("GPL v2"); +
--
Martin K. Petersen Oracle Linux Engineering