Re: [PATCH] block: fix userspace documentation reference for del_gendisk()
From: Luis Chamberlain <mcgrof@kernel.org>
Date: 2021-04-23 18:38:50
Also in:
lkml
From: Luis Chamberlain <mcgrof@kernel.org>
Date: 2021-04-23 18:38:50
Also in:
lkml
*Poke* This documentation fix is not merged yet. Luis On Tue, Nov 17, 2020 at 02:06:58PM +0000, Luis Chamberlain wrote:
Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount helpers") has a typo where it references drivers for del_gendisk() when we instead meant userspace, as the reference is to the userspace experience. This fixes this. Signed-off-by: Luis Chamberlain <mcgrof@kernel.org> --- block/genhd.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)diff --git a/block/genhd.c b/block/genhd.c index 0a273211fec2..9511620f558a 100644 --- a/block/genhd.c +++ b/block/genhd.c@@ -880,8 +880,8 @@ static void invalidate_partition(struct gendisk *disk, int partno) * with put_disk(), which should be called after del_gendisk(), if * __device_add_disk() was used. * - * Drivers exist which depend on the release of the gendisk to be synchronous, - * it should not be deferred. + * Userspace may exist which depends on the release of the gendisk to be + * synchronous, it should not be deferred. * * Context: can sleep */-- 2.28.0