Re: [PATCH 4/4] block: call blk_additional_{latency,sector} only when io_extra_stats is true From: Guoqing Jiang <hidden> Date: 2021-01-28 02:54:53 Hi Christoph, On 1/27/21 18:09, Christoph Hellwig wrote:On Wed, Jan 27, 2021 at 03:59:30PM +0100, Guoqing Jiang wrote:quoted+ if (blk_queue_io_extra_stat(req->q)) + blk_additional_sector(req->part, sgrp, bytes >> SECTOR_SHIFT); This is completely unreadable due to the long line. Hmm, then how about move the check into blk_additional_{sector,latency} to make the code more readable. Thanks, Guoqing
Keyboard shortcuts hback out one level jnext message in thread kprevious message in thread ldrill in Escclose help / fold thread tree ?toggle this help