Thread (13 messages) flat view 13 messages, 4 authors, 2021-02-21
STALE2042d REVIEWED: 1 (0M)

1 review trailer.

[PATCH 5/9] n64: use sector SECTOR_SHIFT instead 512

From: Chaitanya Kulkarni <hidden>
Date: 2021-01-25 23:37:36
Also in: linux-mips
Subsystem: block layer, the rest · Maintainers: Jens Axboe, Linus Torvalds

Instead of using magic numbers use SECTOR_SHIFT to get the number of
sectors from the size.

Signed-off-by: Chaitanya Kulkarni <redacted>
Reviewed-by: Lauri Kasanen <redacted>
---
 drivers/block/n64cart.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/block/n64cart.c b/drivers/block/n64cart.c
index 620f9e080d5d..c83a6af5a718 100644
--- a/drivers/block/n64cart.c
+++ b/drivers/block/n64cart.c
@@ -157,7 +157,7 @@ static int __init n64cart_probe(struct platform_device *pdev)
 	disk->fops = &n64cart_fops;
 	strcpy(disk->disk_name, "n64cart");
 
-	set_capacity(disk, size / 512);
+	set_capacity(disk, size >> SECTOR_SHIFT);
 	set_disk_ro(disk, 1);
 
 	blk_queue_flag_set(QUEUE_FLAG_NONROT, queue);
-- 
2.22.1
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help