Thread (7 messages) flat view 7 messages, 3 authors, 2021-01-19

Re: [PATCH] block: Add bio_limit

From: Christoph Hellwig <hch@lst.de>
Date: 2021-01-19 06:24:49
Also in: linux-fsdevel

On Mon, Jan 18, 2021 at 11:52:10PM +0000, Damien Le Moal wrote:
What about calling it bio_max_bvecs() or bio_max_segs() ? Together with renaming
BIO_MAX_PAGES to BIO_MAX_SEGS or BIO_MAX_BVECS, things would be clear on what
this is referring to. Since these days one bvec is one seg, but segment is more
struct request layer while bvec is more BIO layer, I would lean toward using
bvec for naming this one, but either way would be fine I think.
That's probably the least bad of the options for now.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help