Re: [PATCH] null_blk: Move the null_blk source files into a subdirectory
From: Jens Axboe <axboe@kernel.dk>
Date: 2020-06-22 03:03:14
On 6/21/20 2:42 PM, Bart Van Assche wrote:
Since the number of source files of the null_blk driver keeps growing,
move these source files into a new subdirectory.
Cc: Christoph Hellwig <hch@lst.de>
Cc: Daniel Wagner <redacted>
Cc: Dongli Zhang <redacted>
Cc: Damien Le Moal <redacted>
Cc: Johannes Thumshirn <redacted>
Cc: Chaitanya Kulkarni <redacted>
Signed-off-by: Bart Van Assche <bvanassche@acm.org>
---
drivers/block/Kconfig | 8 +-------
drivers/block/Makefile | 7 +------
drivers/block/null_blk/Kconfig | 9 +++++++++
drivers/block/null_blk/Makefile | 8 ++++++++
drivers/block/{ => null_blk}/null_blk.h | 0
drivers/block/{ => null_blk}/null_blk_main.c | 0
drivers/block/{ => null_blk}/null_blk_trace.c | 0
drivers/block/{ => null_blk}/null_blk_trace.h | 0
drivers/block/{ => null_blk}/null_blk_zoned.c | 0
9 files changed, 19 insertions(+), 13 deletions(-)
create mode 100644 drivers/block/null_blk/Kconfig
create mode 100644 drivers/block/null_blk/Makefile
rename drivers/block/{ => null_blk}/null_blk.h (100%)
rename drivers/block/{ => null_blk}/null_blk_main.c (100%)
rename drivers/block/{ => null_blk}/null_blk_trace.c (100%)
rename drivers/block/{ => null_blk}/null_blk_trace.h (100%)
rename drivers/block/{ => null_blk}/null_blk_zoned.c (100%)I'm all for this since, but why not name them null_blk/main.c etc? A bit annoying/redundant to have them be drivers/block/null_blk/null_main.c and so forth. Probably have null_blk.h be the exception. -- Jens Axboe