Thread (3 messages) 3 messages, 3 authors, 2020-03-26

Re: [PATCH v7 0/6] block: Introduce REQ_ALLOCATE flag for REQ_OP_WRITE_ZEROES

From: Christoph Hellwig <hch@infradead.org>
Date: 2020-03-26 14:46:27
Also in: dm-devel, lkml

Possibly related (same subject, not in this thread)

On Thu, Mar 26, 2020 at 10:34:42AM -0400, Martin K. Petersen wrote:
I just worry about the proliferation of identical merging and splitting
code throughout the block stack as we add additional single-range, no
payload operations (Verify, etc.). I prefer to enforce the semantics in
the LLD and not in the plumbing. But I won't object to a separate
REQ_OP_ALLOCATE if you find the resulting code duplication acceptable.
I find it acceptable for now.  And I think we should find some way
(e.g. by being table driven) to share code between differnet opcodes.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help