Thread (12 messages) 12 messages, 4 authors, 2020-03-12

Re: [PATCH v2 0/5] Add support for block disk resize notification

From: Singh, Balbir <hidden>
Date: 2020-03-12 22:51:54
Also in: linux-nvme, lkml

On Thu, 2020-03-12 at 08:06 -0600, Jens Axboe wrote:
On 3/2/20 9:03 PM, Singh, Balbir wrote:
quoted
On Tue, 2020-02-25 at 20:01 +0000, Balbir Singh wrote:
quoted
Allow block/genhd to notify user space about disk size changes using a
new helper set_capacity_revalidate_and_notify(), which is a wrapper
on top of set_capacity(). set_capacity_revalidate_and_notify() will only
notify
iff the current capacity or the target capacity is not zero and the
capacity really changes.

Background:

As a part of a patch to allow sending the RESIZE event on disk capacity
change, Christoph (hch@lst.de) requested that the patch be made generic
and the hacks for virtio block and xen block devices be removed and
merged via a generic helper.

This series consists of 5 changes. The first one adds the basic
support for changing the size and notifying. The follow up patches
are per block subsystem changes. Other block drivers can add their
changes as necessary on top of this series. Since not all devices
are resizable, the default was to add a new API and let users
slowly convert over as needed.

Testing:
1. I did some basic testing with an NVME device, by resizing it in
the backend and ensured that udevd received the event.


Changelog v2:
- Rename disk_set_capacity to set_capacity_revalidate_and_notify
- set_capacity_revalidate_and_notify can call revalidate disk
  if needed, a new bool parameter is passed (suggested by Bob Liu)
Ping? It's not an urgent patchset, I am happy to wait if nothing else is
needed.
It doesn't apply to the 5.7 branches, can you resend against for-5.7/block?
Thanks, I'll take a look. I used the latest next (next-20200312) and rebased
on it. I got a three way merge success on xen-blkfront

Using index info to reconstruct a base tree...
M       drivers/block/xen-blkfront.c
Falling back to patching base and 3-way merge...

I presume you are running into the same thing.

I will resend the patches on top of next shortly

Balbir
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help