Thread (3 messages) 3 messages, 1 author, 2019-07-14

Re: [PATCH] driver: block: nbd: Replace magic number 9 with SECTOR_SHIFT

From: Marcos Paulo de Souza <hidden>
Date: 2019-07-14 04:08:44
Also in: lkml

ping?

On Tue, Jul 02, 2019 at 07:55:21PM -0300, Marcos Paulo de Souza wrote:
ping?

On Mon, Jun 24, 2019 at 01:09:33PM -0300, Marcos Paulo de Souza wrote:
quoted
set_capacity expects the disk size in sectors of 512 bytes, and changing
the magic number 9 to SECTOR_SHIFT clarifies this intent.

Signed-off-by: Marcos Paulo de Souza <redacted>
---
 drivers/block/nbd.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/block/nbd.c b/drivers/block/nbd.c
index 3a9bca3aa093..fd3bc061c600 100644
--- a/drivers/block/nbd.c
+++ b/drivers/block/nbd.c
@@ -288,7 +288,7 @@ static void nbd_size_update(struct nbd_device *nbd)
 	}
 	blk_queue_logical_block_size(nbd->disk->queue, config->blksize);
 	blk_queue_physical_block_size(nbd->disk->queue, config->blksize);
-	set_capacity(nbd->disk, config->bytesize >> 9);
+	set_capacity(nbd->disk, config->bytesize >> SECTOR_SHIFT);
 	if (bdev) {
 		if (bdev->bd_disk) {
 			bd_set_size(bdev, config->bytesize);
-- 
2.21.0
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help