Thread (2 messages) 2 messages, 2 authors, 2019-06-28

Re: [PATCH] block: Rename hd_struct.policy into hd_struct.read_only

From: Bart Van Assche <bvanassche@acm.org>
Date: 2019-06-28 20:26:04

On 6/28/19 1:09 PM, Martin K. Petersen wrote:
Bart,
quoted
Since nobody knows what "policy" means, rename the field to "read_only"
for clarity. Martin Petersen proposed this earlier - see also his patch
"scsi: sd: block: Fix regressions in read-only block device handling"
(https://www.spinics.net/lists/linux-scsi/msg129146.html). This patch
is an extension of a subset of Martin's patch.
I'd rather we just get this one merged:

	https://patchwork.kernel.org/patch/10967367/

It even comes with a shiny blktest.
Ah, I had overlooked that patch.

Jens, please drop my patch.

Bart.

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help