On 2/14/19 12:04 AM, Theodore Y. Ts'o wrote:
On Wed, Feb 13, 2019 at 05:50:36PM +0800, Bob Liu wrote:
quoted
@nr_mirrors is 1 by default which means only one copy, drivers e.g raid1 are
responsible for setting the right value. The maximum value is
BITS_PER_LONG which is 32 or 64. That should be big enough else retry lantency
may be too high.
This is admittedly bike-shedding, so feel free to ignore, but...
In the case of Raid 6, "mirrors" will be a bit of a misnomer. Would
"nr_recovery" be better?
Now the initial/default value is 1 indicating only one copy of data.
Would nr_copy be more accurate?
Thanks for working on this!! I would be interested in using this for
ext4 once it's available.
- Ted