Re: [PATCH v3 07/16] block: sed-opal: reuse response_get_token to decrease code duplication
From: Scott Bauer <hidden>
Date: 2019-01-27 21:06:31
Also in:
lkml
From: Scott Bauer <hidden>
Date: 2019-01-27 21:06:31
Also in:
lkml
On Tue, Jan 22, 2019 at 11:31:38PM +0100, David Kozub wrote:
response_get_token had already been in place, its functionality had
been duplicated within response_get_{u64,bytestring} with the same error
handling. Unify the handling by reusing response_get_token within the
other functions.
Co-authored-by: Jonas Rabenstein [off-list ref]
Signed-off-by: David Kozub <redacted>
Signed-off-by: Jonas Rabenstein <redacted>Reviewed-by: Scott Bauer <redacted>