Re: [PATCH V14 0/3] blk-mq: refactor and fix the code of issue directly
From: Jens Axboe <axboe@kernel.dk>
Date: 2018-12-14 19:33:06
Also in:
lkml
From: Jens Axboe <axboe@kernel.dk>
Date: 2018-12-14 19:33:06
Also in:
lkml
On 12/13/18 6:28 PM, Jianchao Wang wrote:
Hi Jens After commit c616cbee ( blk-mq: punt failed direct issue to dispatch list ), we always insert request to hctx dispatch list whenever get a BLK_STS_RESOURCE or BLK_STS_DEV_RESOURCE, this is overkill and will harm the merging. We just need to do that for the requests that has been through .queue_rq. This patch set fixes the issue above and refactors the code of issue request directly to unify the interface and make the code clearer and more readable. Please consider this patchset for 4.21.
Applied, thanks Jianchao. -- Jens Axboe