Re: [PATCH v3 11/49] btrfs: avoid access to .bi_vcnt directly
From: Ming Lei <hidden>
Date: 2017-10-19 22:57:44
Also in:
linux-btrfs, linux-fsdevel, linux-mm, lkml
From: Ming Lei <hidden>
Date: 2017-10-19 22:57:44
Also in:
linux-btrfs, linux-fsdevel, linux-mm, lkml
On Thu, Aug 10, 2017 at 04:29:59AM -0700, Christoph Hellwig wrote:
quoted
+static unsigned int get_bio_pages(struct bio *bio) +{ + unsigned i; + struct bio_vec *bv; + + bio_for_each_segment_all(bv, bio, i) + ; + + return i; +}s/get_bio_pages/bio_nr_pages/ ?
Yeah, the name of bio_nr_pages() is much better.
Also this seems like a useful helper for bio.h
OK. -- Ming