On Thu, Aug 10, 2017 at 2:08 PM, Adrian Hunter [off-list ref] wrote:
Most of the information needed to issue requests to a CQE is already in
struct mmc_request and struct mmc_data. Add data block address, some flags,
and the task id (tag), and allow for cmd being NULL which it is for CQE
tasks.
Signed-off-by: Adrian Hunter <adrian.hunter@intel.com>
+ int tag;
Is this consistent with the block layer idea of "tag"?
I am asking because I get confused.
I thought the block layers idea of a "tag" was some metadata
associated with a request. Not that I am a block layer expert.
Why can't we just name this "task_id" if that is what it is in
Linux terms? Does the specification call it "tag"?
Yours,
Linus Walleij