Hi Christoph,
On 15 Oct 2021, at 14:26, Christoph Hellwig [off-list ref] wrote:
Add a helpe to query the size of a block device in bytes. This
will be used to remove open coded access to ->bd_inode.
Matthew already pointed out the return type for bdev_nr_bytes() but also your commit message has a typo: "Add a helpe" -> "Add a helper".
Best regards,
Anton
quoted hunk ↗ jump to hunk
Signed-off-by: Christoph Hellwig <hch@lst.de>
---
include/linux/genhd.h | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/include/linux/genhd.h b/include/linux/genhd.h
index 082a3e5fd8fa1..f67db3c5a04b3 100644
--- a/include/linux/genhd.h
+++ b/include/linux/genhd.h
@@ -235,9 +235,14 @@ static inline sector_t get_start_sect(struct block_device *bdev)
return bdev->bd_start_sect;
}
+static inline sector_t bdev_nr_bytes(struct block_device *bdev)
+{
+ return i_size_read(bdev->bd_inode);
+}
+
static inline sector_t bdev_nr_sectors(struct block_device *bdev)
{
- return i_size_read(bdev->bd_inode) >> 9;
+ return bdev_nr_bytes(bdev) >> SECTOR_SHIFT;
}
static inline sector_t get_capacity(struct gendisk *disk)
--
2.30.2