[v2 1/8] dt-bindings: iio: adc: rename the aspeed adc yaml
From: Jonathan Cameron <hidden>
Date: 2021-07-23 14:45:31
Also in:
linux-arm-kernel, linux-devicetree, linux-iio, lkml
On Fri, 23 Jul 2021 16:16:14 +0800 Billy Tsai [off-list ref] wrote:
The aspeed,ast2400-adc.yaml not only descriptor the bindings of ast2400. Rename it to aspeed,adc.yaml for all of the aspeed adc bindings. Signed-off-by: Billy Tsai <billy_tsai@aspeedtech.com>
We try to avoid 'wild' card type namings most of the time and instead name after a particular part number. I say try because clearly we let a few in over the years :( It is very hard to know if this binding will apply to 'all' future aspeed ADCs. As such I'm not sure this particular rename makes sense. Thanks, Jonathan
quoted hunk ↗ jump to hunk
--- .../iio/adc/{aspeed,ast2400-adc.yaml => aspeed,adc.yaml} | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) rename Documentation/devicetree/bindings/iio/adc/{aspeed,ast2400-adc.yaml => aspeed,adc.yaml} (93%)diff --git a/Documentation/devicetree/bindings/iio/adc/aspeed,ast2400-adc.yaml b/Documentation/devicetree/bindings/iio/adc/aspeed,adc.yaml similarity index 93% rename from Documentation/devicetree/bindings/iio/adc/aspeed,ast2400-adc.yaml rename to Documentation/devicetree/bindings/iio/adc/aspeed,adc.yaml index 7f534a933e92..23f3da1ffca3 100644 --- a/Documentation/devicetree/bindings/iio/adc/aspeed,ast2400-adc.yaml +++ b/Documentation/devicetree/bindings/iio/adc/aspeed,adc.yaml@@ -1,7 +1,7 @@ # SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause) %YAML 1.2 --- -$id: http://devicetree.org/schemas/iio/adc/aspeed,ast2400-adc.yaml# +$id: http://devicetree.org/schemas/iio/adc/aspeed,adc.yaml# $schema: http://devicetree.org/meta-schemas/core.yaml# title: ADC that forms part of an ASPEED server management processor.