On 1/21/21 7:23 PM, Andrew Jeffery wrote:
Randy found that with the following Kconfig settings we have duplicate
definitions (e.g. __inittest()) in sdhci-of-aspeed due to competing
module_init()/module_exit() calls from kunit and driver the itself.
CONFIG_MMC_SDHCI_OF_ASPEED=m
CONFIG_MMC_SDHCI_OF_ASPEED_TEST=y
Conditionally open-code the kunit initialisation to avoid the error.
Fixes: 7efa02a981d6 ("mmc: sdhci-of-aspeed: Add KUnit tests for phase calculations")
Reported-by: Randy Dunlap <rdunlap@infradead.org>
Signed-off-by: Andrew Jeffery <redacted>
Acked-by: Randy Dunlap <rdunlap@infradead.org> # build-tested
Thanks.
---
drivers/mmc/host/sdhci-of-aspeed-test.c | 9 ++++++++-
drivers/mmc/host/sdhci-of-aspeed.c | 27 ++++++++++++++++++++-----
2 files changed, 30 insertions(+), 6 deletions(-)
--
~Randy
RFC: Features and documentation: http://lwn.net/Articles/260136/