Thread (5 messages) flat view 5 messages, 2 authors, 4d ago

Re: [PATCH 1/2] i2c: i2c-core-acpi: use named initializers for acpi_device_id

From: Mika Westerberg <mika.westerberg@linux.intel.com>
Date: 2026-09-21 04:50:07
Also in: chrome-platform, imx, linux-acpi, linux-arm-msm, linux-i2c, linux-tegra, lkml

On Fri, Sep 18, 2026 at 02:01:50PM +0100, Pawel Zalewski wrote:
Use a designated initializer for the acpi_device_id fields which makes the
code more readable and consistent with how lists are initialized in the
rest of the kernel code base. Also drop explicitly setting fields to 0
where it is redundant.

Unify the list terminator to have a single space between the brackets and
no trailing comma.

Signed-off-by: Pawel Zalewski <redacted>
Acked-by: Mika Westerberg <westeri@kernel.org>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help