[PATCH v2 0/4] dma: use designated initializers for acpi_device_id
From: Pawel Zalewski <hidden>
Date: 2026-09-07 15:18:05
Also in:
dmaengine, linux-arm-msm, lkml
This series is converting lists that contain the acpi_device_id struct, which is defined in the include/linux/device-id/acpi.h to make use of named initializers (which they do not use currently). This work is part of the on going effort in the kernel associated with device-ids [1] The plan is to convert acpi_device_id::driver_data to have an anonymous union, similarly to what was introduced for PCI and I2C device ID tables. The goal is to increase type-safety (most of the existing casts are gone), to improve readability and to make use intent a bit more clear:
union {
kernel_ulong_t driver_data;
const void *driver_data_ptr;
}
But for that to work all lists containing the structs need to use named initializers first to avoid triggering -Wmissing-braces. I already have patches that implement this and touching a lot of kernel subsystmes that use the acpi_device_id struct and that list keeps on growing. Therefore, I have decided to split the series per every subsystem into: - pre-clean-ups that convert the lists to use named initializers (which is this series) - actual implementations that make some of the modules use the new driver_data_ptr member That way the task can be fragmented into manageable and independent chunks of work and makes this effort easier to review. Tested builds on x86-64 and a64 in Yocto using 7.3-rc2. [1] https://lore.kernel.org/all/cover.1780048925.git.u.kleine-koenig@baylibre.com/ (local) Signed-off-by: Pawel Zalewski <redacted> --- Changes in v2: - Tidy up messages and wrapped at 75 chars; added Reviewed-bys from V1. - Link to v1: https://patch.msgid.link/20260904-acpi-dma-v1-0-0fcc63d65d4b@thegoodpenguin.co.uk To: Viresh Kumar <vireshk@kernel.org> To: Andy Shevchenko <andriy.shevchenko@linux.intel.com> To: Vinod Koul <vkoul@kernel.org> To: Frank Li <Frank.Li@kernel.org> To: Binbin Zhou <zhoubinbin@loongson.cn> To: Sinan Kaya <okaya@kernel.org> Cc: dmaengine@vger.kernel.org Cc: linux-kernel@vger.kernel.org Cc: linux-arm-kernel@lists.infradead.org Cc: linux-arm-msm@vger.kernel.org --- Pawel Zalewski (4): dma: dw: use designated initializers for acpi_device_id dma: loongson: use named initializers for acpi_device_id dma: qcom: use named initializers for acpi_device_id dma: xgene-dmac: use named initializers for acpi_device_id drivers/dma/dw/platform.c | 12 ++++++------ drivers/dma/loongson/loongson2-apb-cmc-dma.c | 4 ++-- drivers/dma/qcom/hidma.c | 8 ++++---- drivers/dma/xgene-dma.c | 4 ++-- 4 files changed, 14 insertions(+), 14 deletions(-) --- base-commit: df2908090cda368b01ff43709f51890076c56157 change-id: 20260904-acpi-dma-ee1add4bae4e Best regards, -- Pawel Zalewski [off-list ref]