Replace PTR_ERR() and %ld with %pe and pass the original pointer directly
to pr_debug() and dev_err(). The %pe format specifier prints a symbolic
error name (e.g. -ENOMEM) when CONFIG_SYMBOLIC_ERRNAME is enabled,
otherwise it falls back gracefully and prints the raw integer value.
This makes messages more readable without any functional change.
Signed-off-by: Sumeet Pawnikar <redacted>
---
drivers/powercap/intel_rapl_msr.c | 4 ++--
drivers/powercap/intel_rapl_tpmi.c | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/powercap/intel_rapl_msr.c b/drivers/powercap/intel_rapl_msr.c
index a34543e66446..46972ee1ff84 100644
--- a/drivers/powercap/intel_rapl_msr.c
+++ b/drivers/powercap/intel_rapl_msr.c
@@ -582,8 +582,8 @@ static int intel_rapl_msr_init(void)
rapl_msr_platdev = platform_device_register_data(NULL, "intel_rapl_msr", 0, def,
sizeof(*def));
if (IS_ERR(rapl_msr_platdev))
- pr_debug("intel_rapl_msr device register failed, ret:%ld\n",
- PTR_ERR(rapl_msr_platdev));
+ pr_debug("intel_rapl_msr device register failed, ret:%pe\n",
+ rapl_msr_platdev);
return 0;
}diff --git a/drivers/powercap/intel_rapl_tpmi.c b/drivers/powercap/intel_rapl_tpmi.c
index 73f36d9c09b1..6baaad3c59ef 100644
--- a/drivers/powercap/intel_rapl_tpmi.c
+++ b/drivers/powercap/intel_rapl_tpmi.c
@@ -408,8 +408,8 @@ static int intel_rapl_tpmi_probe(struct auxiliary_device *auxdev,
trp->rp = rapl_add_package(info->package_id, &trp->priv, false);
if (IS_ERR(trp->rp)) {
- dev_err(&auxdev->dev, "Failed to add RAPL Domain for Package%d, %ld\n",
- info->package_id, PTR_ERR(trp->rp));
+ dev_err(&auxdev->dev, "Failed to add RAPL Domain for Package%d, %pe\n",
+ info->package_id, trp->rp);
ret = PTR_ERR(trp->rp);
goto err;
}--
2.43.0