Thread (59 messages) 59 messages, 6 authors, 15d ago

Re: [PATCH v7 02/23] KVM: Make device name configurable

From: Sean Christopherson <seanjc@google.com>
Date: 2026-09-03 15:48:37
Also in: kvm, kvmarm, linux-s390, lkml

On Thu, Sep 03, 2026, Steffen Eiden wrote:
On Wed, Sep 02, 2026 at 09:14:21AM -0700, Sean Christopherson wrote:
quoted
On Wed, Sep 02, 2026, Steffen Eiden wrote:
quoted
On Tue, Sep 01, 2026 at 05:40:25PM -0700, Sean Christopherson wrote:
quoted
On Mon, Aug 31, 2026, Steffen Eiden wrote:
quoted
Allow KVM implementations to choose alternative device names. This is
especially useful for architectures providing multiple KVM
implementations simultaneously. Architectures providing multiple KVM
implementations must compile the KVM common code once per
implementation and mange symbols.
What about tracepoints?  Or do those show up as "kvm" and "kvm-arm64"?
Yes, I want them to show up as kvm and  kvm-arm64.

Thanks for pointing that out - I just noticed that I forgot to switch
the trace system to kvm-arm64 for the common tracepoints in
trace/events/kvm.h
I only did it for the arch-local traces in PATCH 21.

I would just do the following:
diff --git a/include/trace/events/kvm.h b/include/trace/events/kvm.h
index b282e3a86769..5d4f8a0693a3 100644
--- a/include/trace/events/kvm.h
+++ b/include/trace/events/kvm.h
@@ -5,7 +5,11 @@
 #include <linux/tracepoint.h>

 #undef TRACE_SYSTEM
+#ifdef KVM_S390_ARM64
Side topic, I recommend choosing a macro name that doesn't have a near-collision
with CONFIG_KVM_S390_ARM64.  This *looks* like a typo, i.e. it looks like you
forgot the CONFIG_ prefix.  Especially since the macro is defined in the Makefile
and won't show up with e.g. "git grep -w KVM_S390_ARM64". E.g. KVM_S390_BUILD_ARM64
or something?
Interesting. The name was deliberately chosen to be similar. But I
see that it could be confusing.

I am not totally happy with KVM_S390_BUILD_ARM64 but I cannot find a
better name either.
Y'all need to pick *one* method.  KVM_S390_MANAGES_S390_GUEST was already added
by a07276d5d188 ("KVM: s390: gmap: Make storage keys optional"), and then this
series effectively adds another macro to provide the inversion of that, except
they're not even tied together.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help