On Sat, Aug 29, 2026 at 11:32:23AM +0530, Aneesh Kumar K.V wrote:
Jason Gunthorpe [off-list ref] writes:
quoted
quoted
The Arm CCA guest driver currently only implements TSM report support, but
follow-up changes will add more TSM-related functionality to the same
module.
Rename arm-cca-guest.c to arm-cca.c and build it as an object of the
arm-cca-guest module. This leaves room for the module to grow additional
source files.
That's pretty confusing, the module is called arm-cc-guest.ko but it
has host items too?
I would have more expected the module to be named arm-cca and this
file to be guest and a future file to be host or something like that?
It is annoying to change module names but we do it, and I think it
should be no problem in this case since there are no users..
But maybe this patch should be in another series..
We have two modules, arm-cca-guest.ko and arm-cca-host.ko, located in
their respective directories:
drivers/virt/coco/arm-cca-guest/
drivers/virt/coco/arm-cca-host/
They also have separate Kconfig symbols, ARM_CCA_GUEST and ARM_CCA_HOST.
So this is about renaming the .c file so you can have a multi .c file
module then? The usual kbuild problem. I'd call it guest-main or
similar. Linus has disliked suttering the directory name into the file
name in the past
Jason