Thread (12 messages) 12 messages, 2 authors, 2d ago

Re: [PATCH net-next v9 1/3] net: airoha: rename airoha_priv_flags to airoha_dev_flags

From: Jacob Keller <jacob.e.keller@intel.com>
Date: 2026-07-20 22:36:59
Also in: linux-mediatek, netdev

On 7/20/2026 3:03 PM, Lorenzo Bianconi wrote:
Rename the airoha_priv_flags enum to airoha_dev_flags and the
AIROHA_PRIV_F_WAN flag to AIROHA_DEV_F_WAN. The "priv_flags" naming
dates back to an earlier design that used ethtool private flags; since
this series switched to tc qdisc offload for LAN/WAN configuration,
align the naming to reflect that these are per-device flags rather than
ethtool private flags. No functional change.

Reviewed-by: Simon Horman <horms@kernel.org>
Reviewed-by: Alexander Lobakin <aleksander.lobakin@intel.com>
Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org>
---
Reviewed-by: Jacob Keller <jacob.e.keller@intel.com>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help