[PATCH v5 0/2] Add Meta(Facebook) ventura2 BMC(AST2600)
From: Kyle Hsieh <hidden>
Date: 2026-06-08 02:40:47
Also in:
linux-aspeed, linux-devicetree, lkml
Summary: Add linux device tree entry related to Meta(Facebook) ventura2. specific devices connected to BMC(AST2600) SoC. Signed-off-by: Kyle Hsieh <redacted> --- Changes in v5: - Addressed review comments: * Added comments explaining the necessity of 'legacy_' prefixes (hardware label collision), pre-allocated I2C aliases (future expansions), and the 'ledd1' naming convention (schematic alignment). * Removed the empty `&mdio0` node to comply with upstream networking subsystem guidelines. * Removed the redundant `&peci0` node. * Sorted `&kcs3` and `&lpc_ctrl` nodes in strict alphabetical order. - Hardware/DT alignment updates: * Removed unpopulated sensors (adi,adt7461, infineon,tda38640, ti,ina230, ti,ina238) to accurately reflect the current board population. * Added the secondary flash node (flash@1 labeled "e810") under the &spi2 bus. - Link to v4: https://lore.kernel.org/r/20260424-ventura2_initial_dts-v4-0-806b00ea4314@gmail.com (local) Changes in v4: - Fixed capitalization: "ventura2" -> "Ventura2". - Reordered I2C child nodes in ascending order of unit addresses. - Enable PECI, LPC control, and KCS3 interfaces for host communication. - Configure MCTP controller on I2C4 and enable MCTP support for specific mux channels. - Add Infineon TDA38640 and TI INA230 power monitor nodes. - GPIO and Pinmux cleanup for PVT: - Aligned gpio-line-names as requested. - Remove unused or non-existent GPIO line names to align with Ventura2 PVT. - Update specific GPIO pins to empty strings where signals were removed or consolidated. - Adjust SGPIOM frequency to 200kHz and update signal line names. - Enable UART3 and add serial2 alias. - Link to v3: https://lore.kernel.org/r/20260113-ventura2_initial_dts-v3-0-2dbfda6a5b47@gmail.com (local) Changes in v3: - Add annotation for marvel 88e6393x - Modify the gpio-line-name - Modify the node order alphabetically - Modify dt-bindings document for rmc instead of bmc - Move the gpio-line-names to original node - Link to v2: https://lore.kernel.org/r/20251224-ventura2_initial_dts-v2-0-f193ba5d4073@gmail.com (local) Changes in v2: - Remove unused mdio - Link to v1: https://lore.kernel.org/r/20251222-ventura2_initial_dts-v1-0-1f06166c78a3@gmail.com (local) --- Kyle Hsieh (2): dt-bindings: arm: aspeed: add Meta ventura2 board ARM: dts: aspeed: ventura2: Add Meta ventura2 BMC .../devicetree/bindings/arm/aspeed/aspeed.yaml | 1 + arch/arm/boot/dts/aspeed/Makefile | 1 + .../dts/aspeed/aspeed-bmc-facebook-ventura2.dts | 2888 ++++++++++++++++++++ 3 files changed, 2890 insertions(+) --- base-commit: 9448598b22c50c8a5bb77a9103e2d49f134c9578 change-id: 20251222-ventura2_initial_dts-909b3277d665 Best regards, -- Kyle Hsieh [off-list ref]