Re: [PATCH] crypto: aspeed/hash: Use memcpy_from_sglist() in aspeed_ahash_dma_prepare()
From: Neal Liu <neal_liu@aspeedtech.com>
Date: 2026-03-30 09:36:37
Also in:
linux-aspeed, linux-crypto, lkml
From: Neal Liu <neal_liu@aspeedtech.com>
Date: 2026-03-30 09:36:37
Also in:
linux-aspeed, linux-crypto, lkml
Replace scatterwalk_map_and_copy() with memcpy_from_sglist() in aspeed_ahash_dma_prepare(). The latter provides a simpler interface without requiring a direction parameter, making the code easier to read and less error-prone. No functional change intended. Signed-off-by: Paul Louvel <redacted> --- drivers/crypto/aspeed/aspeed-hace-hash.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)diff --git a/drivers/crypto/aspeed/aspeed-hace-hash.c b/drivers/crypto/aspeed/aspeed-hace-hash.c index f8f37c9d5f3c..6f0d03cfbefc 100644 --- a/drivers/crypto/aspeed/aspeed-hace-hash.c +++ b/drivers/crypto/aspeed/aspeed-hace-hash.c@@ -182,8 +182,7 @@ static int aspeed_ahash_dma_prepare(struct aspeed_hace_dev *hace_dev)final = true; } else length -= remain; - scatterwalk_map_and_copy(hash_engine->ahash_src_addr, rctx->src_sg, - rctx->offset, length, 0); + memcpy_from_sglist(hash_engine->ahash_src_addr, rctx->src_sg, rctx->offset, length); aspeed_ahash_update_counter(rctx, length); if (final) length += aspeed_ahash_fill_padding( -- 2.53.0
Reviewed-by: Neal Liu <neal_liu@aspeedtech.com>