On Fri, 06 Mar 2026 11:04:56 +0800, Sherry Sun wrote:
The imx_pcie_assert_core_reset() and imx_pcie_deassert_core_reset()
functions are primarily intended to reset the RC controller itself, not
the remote PCIe endpoint devices. However, the PERST# GPIO control was
previously embedded within these functions, which conflates two distinct
reset operations.
Move the PERST# GPIO handling into a dedicated function
imx_pcie_assert_perst(). This makes the code more maintainable and
prepares for parsing the reset-gpios property according to the new
Root Port DT binding in subsequent patches.
[...]
Applied, thanks!
[1/1] PCI: imx6: Separate PERST# assertion from core reset functions
commit: 180ea823bb45eb71dd5ed0dc0b78633accd21096
Best regards,
--
Manivannan Sadhasivam [off-list ref]