Re: [PATCH] PCI: mediatek-gen3: select PCI_PWRCTRL_GENERIC correctly
From: Bjorn Helgaas <helgaas@kernel.org>
Date: 2026-03-23 17:24:48
Also in:
linux-mediatek, linux-pci, lkml
On Mon, Mar 23, 2026 at 05:26:47PM +0530, Manivannan Sadhasivam wrote:
On Mon, Mar 23, 2026 at 11:55:06AM +0100, Arnd Bergmann wrote:quoted
From: Arnd Bergmann <arnd@arndb.de> The PCI_PWRCTRL_SLOT option was renamed to PCI_PWRCTRL_GENERIC, but a new user showed up using the old name, which caused a build failure when both conflicting patches are merged: aarch64-linux-ld: drivers/pci/controller/pcie-mediatek-gen3.o: in function `mtk_pcie_remove': pcie-mediatek-gen3.c:(.text+0x137c): undefined reference to `pci_pwrctrl_power_off_devices' Use the correct symbol as intended originally. Fixes: ff124bbbca1d ("PCI/pwrctrl: generic: Rename pci-pwrctrl-slot as generic") Fixes: 073a7e1b7bcc ("PCI: mediatek-gen3: Integrate new pwrctrl API") Signed-off-by: Arnd Bergmann <arnd@arndb.de>Bjorn, should I squash this fix with 073a7e1b7bcc so that pci/next will build properly?
If you squash this into 073a7e1b7bcc, I think the 0-day bot will comlain about the resulting pci/controller/mediatek-gen3 branch because it doesn't include ff124bbbca1d. I can resolve it by hand when merging pci/controller/mediatek-gen3 into pci/next.
quoted
--- drivers/pci/controller/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)diff --git a/drivers/pci/controller/Kconfig b/drivers/pci/controller/Kconfig index e72ac6934379..686349e09cd3 100644 --- a/drivers/pci/controller/Kconfig +++ b/drivers/pci/controller/Kconfig@@ -222,7 +222,7 @@ config PCIE_MEDIATEK_GEN3 depends on ARCH_AIROHA || ARCH_MEDIATEK || COMPILE_TEST depends on PCI_MSI select IRQ_MSI_LIB - select PCI_PWRCTRL_SLOT + select PCI_PWRCTRL_GENERIC help Adds support for PCIe Gen3 MAC controller for MediaTek SoCs. This PCIe controller is compatible with Gen3, Gen2 and Gen1 speed,-- 2.39.5-- மணிவண்ணன் சதாசிவம்