Re: [PATCH v3] PCI/TPH: Fix get cpu steer-tag fail on ARM64 platform
From: fengchengwen <hidden>
Date: 2026-03-09 04:18:48
Also in:
linux-acpi, linux-doc, linux-pci, linux-perf-users, linux-riscv, lkml, loongarch, stable
On 3/6/2026 6:01 PM, Jonathan Cameron wrote:
On Fri, 6 Mar 2026 10:19:17 +0800 Chengwen Feng [off-list ref] wrote:quoted
Currently the pcie_tph_get_cpu_st() has an issue on ARM64 platform: 1. The pcie_tph_get_cpu_st() function directly uses cpu_uid as the input parameter to call the PCI ACPI DSM method. According to the DSM definition, the input value should be the ACPI Processor UID (see [1] for details). 2. In the Broadcom driver implementation [2] (which invokes pcie_tph_get_cpu_st()), cpu_uid is obtained via cpumask_first(irq->cpu_mask) - this is the logical CPU ID of a CPU core, generated and managed by kernel (e.g., [0,255] for a system with 256 logical CPU cores). 3. On ARM64 platforms, ACPI assigns Processor UID to cores listed in the MADT table, and this UID may not match the kernel's logical CPU ID. As a result, the current implementation fails to retrieve the correct CPU steer-tag in such cases. 4. The function works on AMD x86 platforms only because the logical CPU ID is identical to the ACPI Processor UID on those systems. This commit fixes it by: 1. For ACPI-enabled platforms, unify the CPU ACPI ID retrieval interface: - On arm64/riscv/loongarch: Rename existing get_acpi_id_for_cpu() to acpi_get_cpu_acpi_id(). - On x86: Add new acpi_get_cpu_acpi_id() implementation that wraps cpu_acpi_id(). 2. Update pcie_tph_get_cpu_st() to use acpi_get_cpu_acpi_id(cpu) to get valid ACPI Processor UID for DSM calls. 3. Renaming pcie_tph_get_cpu_st()'s input parameter cpu_uid to cpu for clarity, as the parameter now represents a logical CPU ID (not a UID). [1] According to ECN_TPH-ST_Revision_20200924 (https://members.pcisig.com/wg/PCI-SIG/document/15470), the input is defined as: "If the target is a processor, then this field represents the ACPI Processor UID of the processor as specified in the MADT. If the target is a processor container, then this field represents the ACPI Processor UID of the processor container as specified in the PPTT." [2] commit c214410c47d6e ("bnxt_en: Add TPH support in BNXT driver") Fixes: d2e8a34876ce ("PCI/TPH: Add Steering Tag support") Cc: stable@vger.kernel.org Signed-off-by: Chengwen Feng <redacted> --- Changes in v3: - Rename existing get_acpi_id_for_cpu() to acpi_get_cpu_acpi_id() other than add one new API.Ah. I wasn't clear around that rename suggestion. Split this into two patches. 1) Rename 2) The new stuff plus x86 implementation.
Hi Jonathan, All fixes are applied in v4. Please review. Thanks.
quoted
Changes in v2: - Add ECN _DSM reference doc name and its URL. - Separate implement acpi_get_cpu_acpi_id() in each arch which supports ACPI. - Refine commit-log. --- Documentation/PCI/tph.rst | 4 ++-- arch/arm64/include/asm/acpi.h | 4 ++-- arch/loongarch/include/asm/acpi.h | 2 +- arch/riscv/include/asm/acpi.h | 2 +- arch/riscv/kernel/acpi_numa.c | 2 +- arch/x86/include/asm/acpi.h | 2 ++ arch/x86/kernel/cpu/common.c | 8 ++++++++ drivers/acpi/pptt.c | 16 ++++++++-------- drivers/acpi/riscv/rhct.c | 2 +- drivers/pci/tph.c | 11 ++++++----- drivers/perf/arm_cspmu/arm_cspmu.c | 2 +- include/linux/pci-tph.h | 4 ++-- 12 files changed, 35 insertions(+), 24 deletions(-)