Thread (4 messages) 4 messages, 2 authors, 2026-03-09
STALE138d
Revisions (2)
  1. rfc [diff vs current]
  2. v2 current

[PATCH v2 0/2] imx8mp-frdm: Enhance code readability

From: Daniel Baluta <daniel.baluta@nxp.com>
Date: 2026-03-02 13:35:34
Also in: imx, linux-devicetree, lkml

Enhance the readability of IOMUXC_SW_PAD_CTL_PAD configuration by using
symbolic macros instead of magic values.

First patch makes MX8MP_I2C_DEFAULT independent of DS so it can be
re-used in multiple places.

Second patch makes uses on the macros introduce with:
31ff1060175c458 ("arm64: dts: imx8mp: Add pinctrl config definitions")
in order to make code easier to read and understand.

Changes since v1:
   * v1: https://lore.kernel.org/imx/20260227130242.1702329-1-daniel.baluta@nxp.com/ (local)
   * remove RFC tag as seems v1 got positive feedback
   * add R-b tag from Maud for patch 1/2
   * update commit message for patch 2/2 as suggested by Frank
   * Use existing macro instead of introducing MX8MP_NAND_DATA_DEFAULT
     as suggested by Maud and Frank

Daniel Baluta (2):
  arm64: dts: imx8mp: Make MX8MP_I2C_DEFAULT independent on drive
    strength
  arm64: dts: imx8mp-frdm: Use symbolic macros for IOMUXC_SW_PAD_CTL_PAD

 arch/arm64/boot/dts/freescale/imx8mp-frdm.dts | 132 +++++++++++-------
 .../arm64/boot/dts/freescale/imx8mp-pinfunc.h |   2 +-
 .../imx8mp-tx8p-ml81-moduline-display-106.dts |  16 +--
 .../boot/dts/freescale/imx8mp-tx8p-ml81.dtsi  |   8 +-
 4 files changed, 97 insertions(+), 61 deletions(-)

-- 
2.45.2

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help