Thread (3 messages) 3 messages, 3 authors, 2026-03-09

Re: [PATCH] firmware: arm_scmi: base: Simplify protocol list size calculation

From: Cristian Marussi <cristian.marussi@arm.com>
Date: 2026-02-28 10:04:05
Also in: arm-scmi, lkml

On Sat, Feb 28, 2026 at 11:37:33AM +0800, Peng Fan (OSS) wrote:
From: Peng Fan <peng.fan@nxp.com>

Replace the open-coded round-up calculation with the kernel's round_up()
helper function for better readability.

The original expression:
  (1 + (loop_num_ret - 1) / sizeof(u32)) * sizeof(u32)
Thanks for this.

LGTM.

Reviewed-by: Cristian Marussi <cristian.marussi@arm.com>

Cristian

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help